I can’t click or move in the animator.,I cannot click and move empty in animator

I can’t click or move in the animator. I can only select the animation through the box selection, but when I right-click, there is no make transition selection.,I can’t click and move in the animator. I can only select the animation through the box selection, but when I right-click, there is no make transition selection.

I ran into this issue too, and found that the problem disappeared in debug mode.

You can switch to debug mode from the “three dot” icon near by the “lock” icon on the title bar of the state property panel. (Don’t know why, I can’t upload the snapshot…)

I was also just looking up this issue. Can’t move any of the states in the Animator window. Hope there is a solution to this.

this bug is also on unity 2020.3.32.f1, but the update to 2020.3.33f1 solves it

hey there! I was just going through the same issue and got the solution by messing around with some combinations and one worked out actually :wink: Just press the (alt) key along with left mouse click and the screen will move. enjoy peeps!

I ran into this issue and just about gave up hope when I saw this thread, but I found a dumb workaround: you grab them with another state using group selection and move them back into the working area.

For me, there was a small invisible box around the “middle” where I could still select things as normal, but all the states outside that were untouchable, like the editor wasn’t receiving a mouse event or something. The reason I had states stranded out there in the first place was because I can still click and drag from within the box to outside, and I was trying to space them out for readability when they got stuck.

So, to rescue your states, you have to use another state that’s inside the safety box (I made a new empty state), box-select the states together, and inch them back inside. As long as you have a working zone somewhere (you can test by attempting to box-select anywhere, because that only works if you start in a working space), you should always be able to get your states back from the cold, dark, vaguely-defined void.

@wangzedong Not sure why I don’t see this fix in this thread. But I finally remembered workaround I found on this forum, the last time I had this issue. Looks like it still works, so will share in, in case anyone else still having this issue. When I maximize the Animator window, the problem seems to vanish. I can move animator states around. But, as soon as I cancel Maximize, the problem reappears: I can’t move the states around. So I am now in the habit of maximizing the window, if I need to do this. And then cancel maximize, when done!

I should note that I don’t have any problems with clicking on the states or right clicking and making transitions, when states are locked. So possible you are having a different issue!

BTW, discovered that this “animator state lock issue” only seems to happen, when the state has transitions attached. As soon as I remove the transitions, the previously non-movable state becomes movable, even when window is not maximized.