I can't add a Module after changing to "UnityHub 3.7.0".

I can no longer add “Android” or “Japanese” Modules.
Older versions had no problem.

How can this be resolved?

Did you install the version of Unity manually, or via the Hub? Because if you did it manually you cannot modify the install via the Hub.

Installed via Hub. There were no problems installing Editor or Build support. Only AndroidSDK, NDK and Japanese Modules fail repeatedly.