I can't change Scenes?

I spent the past 3 hours figuring out why I can’t change scenes. I watched a number of videos, followed exactly what they have done, and nothing has worked. It seems that my button is not interact able even though it is checked that it is interact able. I figured this because when I hover the button it doesn’t light up or do anything. Pictures below of my script and setup.alt text

P.S. I also need to change the scene using a trigger collision while playing the game (like a portal system). I tried doing this using a trigger script I saw in a video and it also didn’t work. But if this too random then ignore this part.

Thank you for replying! It is a canvas but the event system might have been deleted and I’m guessing that is what the issue is (I forgot UI comes with Event Systems and at the time I didn’t know what they were). Is there a way to attach an event system to the canvas? I see it in the create option but I don’t know how to associate it to the UI.

When I create the event system, it automatically creates it inside the canvas. This is what it looks like. The button still does not work =(. 108451-4.png

Thank you for your responses =), greatly appreciate it.

You need a event system in your scene. 108456-untitled.png