I can't choose a device in editor settings

I’m trying to connect my Android with Unity Remote 5 but in the editor there is no setting to select a device

Your Inspector is in Debug Mode.

Click on the little gear at the top right of the inspector and change to “Normal mode”