I can't raise/lower my terrain

So I’m able to access the edit buttons and the little blue preview marker is appearing just fine, but when I click with my mouse to change the terrain nothing happens.

I’ve tried other methods to fix this (most notably the window default fix) and none have worked.

I’m super new to unity just for the record

Any ideas?

I am also super new to Unity and going through MisterNinjaBoy’s intro tutorial. Starting from a brand new install of Unity 5.4.1f1 and a new project, I got to the section on raising and lowering the terrain and it just didn’t work.

After messing around with randomly clicking every control on the screen, I found that when I selected another object in the Hierarchy tab, and then clicked on the terrain in the scene view, it started working. I also noticed that selecting different terrain editing modes didn’t actually change the mode until I selected a different object and then came back to the terrain I wanted to work on.

It is unsettling to run into something like this during my first hour of trying to learn Unity, and it makes me think this probably wasn’t a planned feature. It also didn’t seem to work every time either, but eventually selecting different objects (even the project itself) and then going back to the terrain from the Scene view got me successfully editing the terrain again.

Being so new, I’m not sure what is going on here. Perhaps someone with more knowledge can shed some light on this.

For me I couldnt lower/raise terrain because I didnt understand what I was doing. The brush size and especially opacity was set too low by default and I couldnt see that I was having any effect on the terrain. I increased those (in the raise terrain tab) and now I’m set until the next misunderstanding. :wink:

Yeah I can confirm it is an opacity setting. Unity is set to 0 by default for some strange reason.

Under the “Brush size” there is something “Opacity”. if thats zero it won’t work. so set opacity 30.

I guess you tried the terrain up/down your brush size is standard 0 make it at least to 1 before it will effect

There are 2 ways to fix this. one is the check the “target strength” that sometimes helps also “opacity” make sure that isn’t on 0 as well. the other way I find is to close Unity and reload it. Both ways work for me I am also new to unity and these ways both work for me hope it helps