I can't see any png files as a source image

I added a png file that has an image and a transparent layer (so basically a border) to the Assets folder but I can’t use it as a source image; the only thing I can do is add it to a material and apply the material to an object, the only problem is I am trying to texturize an UI Image object.

Unfortunately, I can’t see the source texture and only applying the material without a source image doesn’t render anything :frowning:

Can anyone give me some pointers on how to treat this aspect ? I’d use a jpg file but I doubt the transparency will hold out as well.

For short, what I want is a camera canvas that has 2 images applied: a background and a border (with a transparent center). The hierarchy looks like this:

  • Canvas
    • Panel
      • BG image (this is a JPG and I can set it as a source image)
        • Border image (this is a PNG - only found as a material)

I can’t seem to get it working :frowning:

Select that image from project window >> go into inspector window and choose texture type from drop down menu i-e Sprite(2D or UI) apply those settings

Without any more information we can’t do a lot but i will leave my set up here, maybe it helps you
alt text

On the left inspector you have the Panel - Left Menu and on the right inspector you have the Image - Border

I had the same issue, I restarted Unity 5.6 and started to work

For anyone having this issue and their texture was set to Sprite 2D, I had to select another, then re-select Sprite 2D and save. Not sure what happened but that worked for me!