I can't see my imported texture (Blender).

So I decided to take my proof of concept game and start fleshing it out with some free 3d models that I’ve found laying around the web simply to see if it looks right or not before I start learning how to use blender. I imported an obj into Blender, saved it as a .blend file added it into my assests folder along with the appropriate texture and material folders that came with the model. When I put an empty object into the world and then drop the asset ontop of it I can see it quite clearly inside the preview window, however when I hit the play button to see what it looks like in the camera it doesn’t show up. However when I look at my “game” preview window I can see the object, move it and manipulate it and do all that jazz but when I go to play it disappears.

I am obviously missing something I am just not sure what I am missing, is anyone able to help me at all?

Most likely you imported the default animation from blender and it keeps playing when you start your game.

This happened to me a few times before I realized what was going on.
Basically the default animation is set to play on “awake” and will move your model to the center of your world.

(example of default animation import from blender)

to fix this simply uncheck the “play automatically” or skip the import of animations.