I have a 10.5.8 Mac OS X and my Unity wont work. Why?

My Mac OS X 10.5.8 has Unity but it wont work, why is this??? I need to know!!

Because Unity 4.3 requires 10.6, as stated here: http://unity3d.com/unity/system-requirements

You need version 10.6 or above.