I have a problem to import UnityEngine.Monetization

Hello, I would greatly appreciate the person who can solve this problem I have had for a few days and I can not decipher the answer.
My problem is in putting ads for android. At the time of executing any announcement I miss two errors.


One of them is that I am missing a file from the inported package: C: \ Users \ User \ Desktop \ linan \ Library \ PackageCache \ com.unity.ads@2.3.1 \ Runtime \ UnityEngine.Advertisements.Editor.dll
that if I eliminate it, it is solved but I am not sure that I have to eliminate it.
and the second error that the console throws at me is that I can not import the monetization package: The type or namespace name ‘Monetization’ does not exist in the namespace ‘UnityEngine’

From what I read in some forums, it is because the ad package was not imported correctly. Nor do I know if it is normal to import only the android pack and for that reason can not use the UnityEngine.Monetization.

Looks like an error I had with package manager using old versions of ad either 2.08 or 2.3.1 - I am assuming you are using the latest version of monetization 3.0.1 from the asset store. After backing up :slight_smile:
open the package Manager (Window > Package Manager ) and then opens ads and upgrade to the latest version probably 3.0.2 . For some reason 2.0.8 is lastest verified version (in 2018.3.6f) . this solved it for me using 2108.3.6f and 2019.1.7b