I have a problem while exporting from blender

Hey guys, so this is my problem :
I created some objects for my little game in blender and I used the transparency in addition to the material in color. But then I exported it to unity and the transparency wasn’t exported with the material. So I know this problem is recurrent and might have been resolved but I searched and I couldn’t find an answer. In fact I saw that I could go to the object material and change the transparency directly in unity but the material/shader section is all in dark grey and I can’t change a thing. So I am asking for your help, if anyone knows how can I manage that, maybe by creating some script or by exporting in a special way or any answer that could solve my problem. Thanks guys :wink:

There’s mention of new methods. There’s this question and also a linked contained there-in

https://answers.unity.com/questions/1472849/blender-importing-materials-textures-incorrect-wit.html?childToView=1473593#comment-1473593

The material/shader part is greyed out because that is the imported material, which you cannot change (wouldn’t make sense). However, I think you can clone those materials (select it and hit ctrl+d) , and then set the Rendering mode to “Transparent”.

After searching around, it seems importing materials is not supported (even though there is an option for it in the import settings). For example, here Eric5h5 confirms it, and this manual page also skips mentioning importing of materials (meaning they are not). The most “helpful” answer I saw was to not use materials from Blender (or any external application), because you will have to recreate them in Unity anyway…

Ok thanks a lot I will try to do as you said and I’ll tell you if it works