I have unchecked "Import Materials" but two texture maps are still being imported.

Is there another setting somewhere for those? It’s a real pain. The meshes are FBX files with animation.

In most of my projects I use a script like this (place it in the Assets/Editor folder):

using UnityEngine;
using UnityEditor;

public class FBXImportSettings : AssetPostprocessor
	void OnPreprocessModel()
		ModelImporter importer = (ModelImporter)assetImporter;

		// Don't import materials
		importer.importMaterials = false;

It will disable material imports. You can also extend this script to automatically set the model scale, animation stuff etc. to your liking.