I need later version than 2.58 blender ?!? I've got 2.65

Blender could not convert the .blend file to FBX file.
You need to use Blender 2.45-2.49 or 2.58 and later versions for direct Blender import to work.

I don’t get it

and IF I export it as FBX file I’ve got problems plane isn’t bouble sided any longer and in blender it is

and I seem I don’t get imported texture

and I seem I didn’t get imported animation

any solution to this?

EDIT:

if anyone wanders how I solved this:

read my post: how to get material/texture/UV mapping from blender to unity

but that’s not all I’ve even found: how to make unity to read blender file works for: Blender 2.65 - Unity 4.0.1.f2

on the bottom there’s attached file download it

copy content to: ~Unity\Data\Tools\

OFC don’t forget to backup that file in case something goes wrong

about double sided plane I could do it with unity double sided shader

but I’ve found a way in blender(off topic):

  1. Select all faces in blender
  2. Shift + D (copies all this faces)
  3. left mouse click (so they are positioned at exact same coords)
  4. Press W
  5. choose Flip Normals (it flips all the faces other way)

“plane isn’t bouble sided any longer and in blender it is” as a rule, unity and game engines do not really have “double sided planes” it’s sort of meaningless in a game engine.

suggest you ask another question - or search on here - “what to do with a double-sided plane from my modelling program?”

usually modellers who build stuff for games, just don’t use supposed double-sided mesh you know?

I strongly suggest you just export to FBX. do not drop Blender files in to Unity.

Please search on here for the millions of questions “how to export an FBX including textures, animations”

note that even if you don’t bother “including” the textures in an FBX file, you simply drop them on in the Editor (if you prefer)

Since this was the first question I bumped into when googling and I didn’t get a straight-away answer, I’ll try to help someone else.

When in Blender, go File → Export → Autodesk FBX

That’s it.

Direct import works fine without any add-ons if you save the Blender file in Object mode and not in Edit mode. (Unity 4.3 / Blender 2.69)

Hi, I got the the problem and I think I have figured out the problem, in my case at least. But I just want to share just in case if anyone has the same problem with me.

Apparently the problem occurred if I switch the input preset to other than blender (maya/max). Because when I tested switching back to 2.68, it works. But when I switch the preset to maya, the problem reoccured. So I tried to switch the 2.69 preset back to blender, everything works fine again.