If timeScale is lowered how can I aviod to get the physics simulation choppy?

A simple script attached to a gravity dragged falling cube:

Time.timeScale=0.1;

And it's fall isn't smooth. Yuk! How could I smooth it out?

(Using Unity 3.1)

You need to reduce the physics timestep ( Time.fixedDeltaTime ) value by a corresponding amount.

If I'm doing slow-motion, I usually do something like this:

Time.timeScale = slowMotionSpeed;
Time.fixedDeltaTime = slowMotionSpeed * 0.02f;

0.02 is the default physics timestep, so this code means the physics maintains its smoothness in proportion to the current timeScale - so you'll get 50 physics steps per frame, regardless of the timescale.

Another Solution would be to enable Interpolation on rigid bodies. This more or less costs the same, but guarantees smooth results.