illuminate all the objects in the scene

Easy question:
Why the hell is my object black I just want to see it without having to do with lights I don’t need it in my project.

If you want to see it without lights, you’ll need to use ambient lighting. It’s enabled by default, but is set to skybox lighting, so you’ll need to run a bake in the lighting settings or change the ambient lighting to use a fixed colour or gradient. If you don’t want lighting at all, then in your shader you can just plug your colour output into the Emission channel rather than the Albedo channel.