I'm unable to see gameobject icons and stuff in scene view.

Not only am I not seeing any gameobject icons, but I also can’t see the direction in which my main camera or directional light is facing. I’ve enabled 3D icons in my scene, but in vain. Is it a glitch, or is there a way around this? Upon selecting a gameobject from the inspector, I can only see the axes, nothing else.

Hi!

Make sure you have the Gizmos button enabled, as you can see here:
160988-gizmos.png


Hope it helps.

@ASiSiN Oh my goodness. You need to get the Gizmo’s button enabled?? Goddamn. Thanks for the help BTW.