Image resolution wrong on import, how to fix?

Hey Guys,

Ive noticed since i started using unity, that it does not import texture files quite as they should be, and has a tendency of blurring them with a lower Image resolution.

Im trying to import my texture file that is 4096 X 4096, since this is the highest image size that unity claims to be able to use, on import it comes in as 1024X1024, i can then click on 4096 in the image size drop-down, but the texture size is 5X as many mega bites, and not at all sharp, leaving black jagged marks at the seams of the model from the background.

Does anyone know how i can force unity to just import as the correct resalution, and not poorly re-sample the image?


To fix it, go into the import settings, and change Filter mode from Bilinear to Point (no filter). It should fix the problem