Immediate "Not Responding" Editor

I have just installed Unity 4.3.4 yesterday, and I have not yet gotten it to succesfuly launch. When I run the .exe, the loading window (with the futuristic cars) apears, but immediately freezes. Hovering over it with the mouse gives the “loading” circle, and it is listed in Task Manager as “Not Responding”. I have tried many solutions found on the internet, including holding Alt on startup, running in compatibility mode, running as administrator, excepting Unity from Data Execution Prevention and checking my drivers via the DXDIAG diagnostic, and nothing has had an effect.

I have emailed Unity support and recieved a reply, but their suggestions (to check the log files and to hold Alt on startup) also had no effect. I have not yet filed a bug report via the Bug Reporter.

There appears to be no error message in the log files, though each time I launch Unity the log has between 1-3 repetitions of the same sequence:

*Built from '' repo; Version is '4.3.4f1 (e444f76e01cd) revision 96603'; Using compiler version '160040219' 
BatchMode: 0, IsHumanControllingUs: 1, StartBugReporterOnCrash: 1, shouldGiveDebuggerChanceToAttach: 0 
Initialize mono
Mono path[0] = 'C:/Program Files (x86)/Unity/Editor/Data/Managed' 
Mono path[1] = 'C:/Program Files (x86)/Unity/Editor/Data/Mono/lib/mono/2.0' 
Mono path[2] = 'C:/Program Files (x86)/Unity/Editor/Data/UnityScript' 
Mono config path = 'C:/Program Files (x86)/Unity/Editor/Data/Mono/etc' 
Using monoOptions --debugger-agent=transport=dt_socket,embedding=1,defer=y* 

I am running Windows 8 on a Qosmio X75 laptop with a GTX770M graphics card. Any help you can provide would be appreciated.

Try checking that you have windows update KB2533623, KB3063858, or KB4457144.

Download for KB3063858

Download for KB4457144