Immersive mode for android and its compatibility

I want to make my game to use the immerse mode, but is it only compatible with API level 19? If I implement this code I found (link text), will devices with lower API level be able to use the game? How do I exactly implement that code?

@demilp immersive mode was introduced in android kitkat (Api level 19) so the code you shown in the link will only work on android devices at or above that api level

For implementing the code you will need to create an android plugin for unity see link : http://docs.unity3d.com/Documentation/Manual/PluginsForAndroid.html and add the code in the activity.

You could also refer to other system UI flags here: https://developer.android.com/reference/android/view/View.html
(Search for SYSTEM_UI_FLAG) and replace the immersive flag with others so that it may work on other android versions

Please check out my “Android Immersive Mode” plugin in the Asset store - Its FREE and simple to use.