Import error with humanoid rig + cannot configure rig

i’ve been trying to fix this issue for days now and i’m at a complete loss as to what to do, id appreciate literally any advice anyone could give me cause nothing i’ve done has worked :sob: i’m JUST trying to change an avatar from generic to humanoid

most of the advice i’ve gotten is to configure the model but i… can’t because of the error

image

what i’ve tried so far:

  • switching from generic back to humanoid
  • checking if there were any parenting issues with the bones
  • checking for any duplicate bones
  • testing different naming conventions for the bones
  • rerigging the model entirely (this was my last ditch effort)
  • using new projects
  • using different versions of unity
  • testing different models in the same project to see if it’s unity or my fault (it’s my fault but i dont know what’s wrong :sob:)
  • changing import + export settings for my fbx (nothing has worked)
  • reimporting the fbx on top of the old one (saw someone said this worked for them; did not work for me)
  • resetting my layout
  • removing additional bones that are also parented to the head so that unity prioritizes the humanoid bones (ended up having the same issue but with the hip bone)
  • added a jaw bone and deleted it to see if it’d make a difference

absolutely ANY advice is welcome i do not know what to do at all, i’ve never had this issue before

My understanding is that Jaw should probably be empty and that Chest rarely gets assigned properly. I’m sure you went into “Configure” and messed with all that right?

Right now my “Configure” button seems to have died, so wish me luck :smiley:

Edit: Oh, looks like I am now having the same issue.