Import package error (ARToolKit)

I need to use ARToolKit for a project I’m working on for school and I keep getting this error while trying to import the package:

“Package corrupted, deduced GUID exists but at different destination path, refusing import.”

Does anybody have any idea what this means? I’ve tried importing it into an empty project as well and I still get this error.

I got that error as well and I also noticed at the very very bottom of the editor window there was a message indicating that I needed to install the Microsoft redist which is part of the ARToolKit tools package. To get it (after importing the package and getting the errors) go to the ARToolKit menu (in the Unity editor) and select “Download Tools”. All this does is redirect you to the download page so you can always just go to GOLDENSLOT88: Link Situs Judi Live Casino Online Resmi dan terbaik Di Indonesia in your browser and hit the “Download Additional Unity Tools” link. This is where the documentation breaks down a bit but this download is a zip file and inside it you’ll find ARUnity5-5.3.2-tools-win\redist\vcredist_x64.exe. Close Unity, install it, reboot and reopen your project and you should be set to go. I got the “SimpleScene.unity” that comes with the package to run using Unity 5.3.4p1 and the ARToolkit Unity package and tools version 5.3.2. You can do the calibration steps using ARUnity5-5.3.2-tools-win\bin\calib_camera.exe. It hung on me when I tried to run it from my git bash prompt so I ran a normal Windows command window as administrator and it worked fine. Once you’ve generated your calibration file you have to move it and rename it according to this documentation.

Hello @prasetion, the latest should be able to import successfully… Unclick the part that changes your DLLs in /Applications… You may need to reinstall Unity if that rewrote what DLLs are already there. It’s strange that Unity would allow you to overwrite those.

Hi there,

I setup Unity completely new today version 5.3.4f1.
Also I downloaded the newest version of the ARToolKit asset package 5.3.2 and I installed the redist package from the tools.

However I’m still getting the GUID error when opening the asset package. Asset/Import package/Custom package
I’m writing ‘opening’ because at this state the package is not jet imported but only showing all its files in the import dialog.
But already the error is visible several times in the Console window.

Any ideas?

(I cannot see a message at the very bottom as indicated by @JeffBail.)

I find useful this answer http://www.artoolkit.com/community/forums/search.php?st=0&sk=t&sd=d&sr=posts&sid=20991f15a9f6a53f378491f6b5c94a0f&author_id=7149&start=90

You should remove unused platforms in /Assets/Plugin/

@vidmandan is it Recommanded ,that have nust Unity Pro Liceince Version to import ARtoolkit or Vuforia Toolkit…???

For me, running Unity as administrator in windows solved the issue. The error messages are there still, but it did import everything successfully where previously an error message was popping up saying import failure