Imported a project from one computer to a new one and it stopped working

I was working on a unity project (2022.3.4f1) on a computer for around 2 months and then I got a new computer. I installed unity on it and used github to pull the project from the cloud. When I opened it and clicked the play button the game would play but none of the scripts which exists in the assests folder work and I would get a bunch of warnings saying " the referenced script NameHere on this behaviour is missing" and I couldnt add any new scripts to any components without getting a “Can’t add script component “NameHere” because the script class cannot be found…” When that failed I used a hard drive to directly get the project from my old pc WHICH STILL WORKS ON THE OLD PC its fine at the old pc, when I did that the project would open and I could properly add scripts but when I clicked on the play button It would do nothing for 8-10 seconds and the entire unity window would just dissapear and crash. Checking the editor.log also gave a bunch of errors. Opening any script on Visual Studio showers me in a bunch of warnings with codes “CS8032” and “USG0001”. I have been working for 3 days to fix this to no avail please let me know what else I can do on top of these things I have already done:

  • Deleted the library folder so unity redownloads it
  • Tried upgrading the project to 2022.3.15.f1
  • Uninstalled Unity and Re-installed
  • Tried making a brand new project to test if scripts still worked (They dont.)

(p.s I quadruple checked the script names to make sure they are alligned with the names in the actual scripts bc thats all the “fixes” cant add script component error)

I hope I was able to give enough details to find some help.