Imported heightmap makes terrain very spiky and incredibly tall.

So I’ve downloaded an image and converted it to a heightmap in gimp (downloaded a plugin that allowed you to export to RAW), however I end up with terrain that looks like this:

http://i.imgur.com/fkIsn8U.png

alt text

Here’s a picture of my heightmap setup:

alt text
What am I doing wrong?

THIS WILL GET RID OF THOSE TALL JAGGED SPIKES!!!

When importing the raw file, switch whatever byte order it selects as default.

Switch your byte order from Windows to Mac.

When I work with raw heightmap files, it has lots of sharp peaks. I use them as a base, then smooth and tweak once imported. A picture of the heightmap you used may be useful as well.

Maybe the resolution of your heightmap raw file may cause this. (i.e. 556w x 372h then you are taking it to a 512x512.)



EDIT
Unable to Add new posts.

No issue with the base PNG File.
I was able to export as a RAW file, and import into Unity as seen below.

Issues could be with your plugin, the image not being set to greyscale.
Lost detailed solution due to restrictions, can’t be bothered retyping, let me know if you get stuck again otherwise mark as correct.

For Unity 2019.3 beta 4 (Terrain Toolkit package), there is no import setting for .raw
But for me it helped opening the file in ImageJ, go Edit>Options>Input/Output and tick Save TIFF and RAW in Intel byteorder