Imported Models Not Rendering Correctly?

First of all, I wasn’t sure if this was the right place to post this, but after looking across the internet I could think of no other place.

I am first and foremost a programmer, however I am trying to get some basics in 3D modeling so I can make my own assets eventually, I recently spent two days making an AK74u that, although simple, I am quite proud of, but when I imported it there was a major problem: a few faces didn’t render in the “right direction” (the side facing the outside it the side that is invisible). To make it more frustrating, the object’s faces are all correct in Blender (my software of choice)

Any help would be greatly appreciated, also as a side note, anyone know why the object doesn’t look as crisp in Unity as in Blender?

If this is the wrong place to ask this, would someone please point me in the right direction.


Blender also has an option to show the normals. So any arrows pointing inwards are wrong. In theory, there’s also a way to specify that blender show things 1-sided (or backface culled.)

The thing is, it probably was wrong in Blender. Some faces were “backwards,” which is what a flipped normal is. Except blender still draws the backwards ones, making it hard to tell.

Unity is going too look worse since blender is devoting the entire computer to making that one thing look good. Unity is using it as part of a game, so ramps the quality down a (small) step to get a decent framerate.

select all polygons in blender/press space/type: flip normals/click on the first option

hope it worked :slight_smile:

enter editmode select all faces and press ctrl + N.

Can You Plz Expalin me the steps of doing that?@zeman97