Imported Prefab from Asset Store Won't Animate

Hi, I’ve been trying to make a temple run type of game where things are constantly spawning and moving towards the player. At each side of the track I am wanting to animate a series of trees that move to give the impression that my player that is staying in the same position is actually moving. The tree object I am using is part of a pack I have got from the asset store.

When trying to do this however none of my animations seem to run when they should, I also tried using the animation component instead of the animator and setting the animation to legacy to see if it would work that way but still no luck.

I know that this is something to do with the gameobject having a baked lightmap so I’ve tried unchecking the lightmap static option etc but it still makes no difference and whenever I try previewing my animation in the scene view whilst the game is running it still shows the outline of the object with the word “static” and nothing I have found so far has seemed to have made a difference.

Any help would be greatly appreciated.

Nevermind, I solved it myself I didn’t even realise there is a static checkbox on the top of the gameobject. I have never really messed with lighting before so I thought it would be much more complicated than it was.