Importing Asset "blender could not convert the .blend file to fbx file"

Hi. I am using version control, and my teammate imported and used a prefab. However, my console log prints a “missing prefab” error.

I tried importing the asset on my side, and there are 4 versions for this model: .blend, .usdz, gLTF, and GLB.

When I try importing the .blend file, I get a “Blender could not convert the .blend file to fbx file” error message, and “Hold on (Busy…)” for too long. I didn’t have Blender software, so I downloaded it and tried again, but it still didn’t work. I also tried the suggested solution in another forum, “modifying the python script to say 3.0.0 instead of 2.80.0,” but I got this message and couldn’t modify the file: “Failed to save ‘Unity-BlenderToFBX.py’: Insufficient permissions. Select ‘Retry as Admin’ to retry as administrator.”

For the .usdz file, I extracted it, but importing the .usdc file didn’t work properly.

For gLTF and GLB, I saw that I should be downloading the GLTFUtility file, but I also saw a YouTube video stating that it no longer works since 2023. I am not sure about this either.

What should I do to solve this error?

1 Like

Have you tried exporting models as fbx?
I have done this multiple times, it works great.
If you havent, follow these steps:

  1. In blender, select the objects and armatures you want
  2. In blender, go to file>Export>Fbx
  3. In blender, turn on “Selected Objects” checkbox, then disable the following objetc types:

a. Empty
b. Camera
c. Lamp
d. other
Keep the armature and mesh options
4. In blender, choose unity project assets folder, then export
5. Model in unity editor’s file explorer, drag created prefab into scene

Note that like all other 3d file types, this wont port materials, as blender and unity have different material systems. If you want to ask how to show materials, reply back. If you need more info, reply back.

Edited:
P.s. just saw you said your friend has blender, send them this

Hi, thanks for reaching out!
Can you tell us what specific version of Blender you installed? We could give it a try on our side.

Also, installing Blender might modify your environment variables such asPATH. Unity needs to be restarted after installing in order to get the new values. Also, the Windows’ default file association gets changed (so Blender will be launched when you try to open a .blend file). Restarting the computer could be a good thing to try.

According to the code, the error message you shared (Blender could not convert the .blend file to fbx file” error message) happens when:

  • application_for_blend_files is launched (this should be Blender)
  • … (here Blender should run the “Unity-BlenderToFBX.py” script)
  • application_for_blend_files exits
  • the Fbx file we expected Blender to export does not exist

You could look into the Blender logs to see if anything happens during the import.
Thinking of it: it would be very handy to get your Unity Editor logs as well, including the Asset Import Worker logs. An easy way to share all of this with us is to submit a bug report.

Let’s handle the Blender issue here in this post. It would be better to open separate ones for each of the USD / GLTF questions, for clarity.

Blender log before imorting


Blender log after importing and restarting the computer.

  • Missing mesh objects

  • the compile error that I am having.

Did your friend follow the text above? It looks like the mesh hasnt been included because they forgot to select the mesh. I left a little piece out, but i heard somewher that you have to select the armature last. Along with this, make sure it is still an fbx, with all meshes in a singualr fbx.