Importing from 3D Max 2010

i have problem when importing with max... i already used FBX importer but... the texture gone and the object doesn't has a collider... did in need to manually put the collider?

Unity has its own set of colliders that you need to use. See the bottom of this page for a list of colliders and how they work.

  • A. Save a max file in your unity asset folder.
  • B. save your textures in unity's asset folder
  • C. Highlight your imported model in unity. And in the import options check generate collider and create materials by material or texture. The click apply

Problems

Only the diffuse texture will pas in unity, the others should be applied manually. Adding loads of collision meshes is not recommended if you are concerned about performance. As spike mentioned add the default unity meshes or if your model is a bit more complicated create a very simple collision mesh in your model and use that for collision. Make the collision invisible and delete the mesh colliders for the rest of the model.