(IN-33047) [1.0.0-pre.44] IL2CPP build not working

When build IL2CPP runtime player build. Entity is not render properly and show nothing but Mono build is working fine.

Do you have error messages in the log? As a workaround, you can try whether setting "Managed Stripping Level" to "Disabled" in your Player settings helps, it has been known to help in some IL2CPP related issues.

The error message refers to Unity.Rendering.LODWorldReferencePoint component. And also sadly setting "Managed Stripping Level" to "Disabled" is not available at IL2CPP.

[spoiler]

ArgumentException: Cannot find TypeIndex for type hash 4459803065892484956. Check in the debug file ExportedTypes.log of your project Logs folder (/Logs) the corresponding Component type name for the type hash 4459803065892484956. And ensure your runtime depends on all assemblies defining the Component types your data uses.

[/spoiler]

It's still worth trying to set it to the lowest allowed level to see if it helps.


Setting "Managed Stripping Level" to "Minimal" is still not working.

I can confirm that this is a known issue and that a fix is being worked on.

2 Likes

You might be able to work around it by creating a system which references it through the type manger (it worked for me with the culling system).

    public partial class PreventStrippingSystem : SystemBase
    {
        protected override void OnCreate()
        {
            base.OnCreate();
            Debug.Log(
                $"Typemanager: {TypeManager.GetTypeInfo<Unity.Rendering.PerInstanceCullingTag>().StableTypeHash}");
        }