In PolySpatial 0.7.1, uGUI elements within the Canvas are displaying in pink

I recently updated to Unity 2022.3.15f1 along with PolySpatial 0.7.1, and I’ve noticed that uGUI elements within the Canvas are displaying in pink. I’ve observed this issue both when running in the Unity Editor and on the simulator. When the Canvas’s Render Mode is set to “Screen Space - Overlay,” it displays correctly, but when set to “World Space,” it turns pink.



Is there any possible cause or solution to this problem that you can think of?

Previously, I was using Unity 2022.3.11f1 with PolySpatial 0.5.0, and during that time, the Canvas displayed correctly even in “Screen Space - Overlay” mode.

Also, it might not be directly related, I’m using the Built-in Renderer Pipeline instead of URP due to migration reasons.

It looks like this was an oversight on our part; we forgot to include built-in targets for the shader graphs that we include with PolySpatial. We’ll fix that in our next release, but this shouldn’t affect builds for the visionOS simulator/device; the UI elements should only appear pink in Unity play mode.

Incidentally, we don’t support “Screen Space - Overlay” mode for PolySpatial/visionOS. All UI should be in world space.

Hi, @kapolka . I’m trying to port our project to visionOS with PolySpatial. I’ve noticed that uGUI elements are displayed in pink. I’m using PolySpatatial 1.0.3 with URP but the UIs are pink. I added a canvas normally and put a button (TextMesh Pro) on its canvas.

If the editor is in play mode, the button will display in pink. Is there a way to set uGUI up? Of cause, it’ll display in pink on the simulator too.

I noticed the same bug

Could you submit a bug report with a repro case and let us know the incident number (IN-#####)? Without more information, it’s difficult to know what the problem might be.

One thing that causes pink UI materials in 1.0.3 is building with no scenes in the build list (which builds the scene open in the editor). We’ll be adding a fix for that, but in the meantime a workaround is to make sure at least one scene is present and checked in the build list.

Thank you for replying. I’ve submitted a bug report. Report number is “CASE IN-68824”. Please check it out.

I checked my settings but the scene that I checked is listed in the build setting.

It looks like you just need to reimport the UI shaders. In the Project tab, under Packages/PolySpatial/Resources/Shaders, right-click on the Shaders folder and select Reimport. Sometimes something goes wrong with the import process.

1 Like

Thank you for your advice! I fixed them with your way.

1 Like