In Unity2022.3 when use ScriptableWizard display "Serialized Data Mode Controller"

9708203--1386821--upload_2024-3-18_21-51-58.png

public class TestWindow : ScriptableWizard
{
    [MenuItem("Tools/ShowWindow")]
    public static void ShowWindow()
    {
        DisplayWizard<TestWindow>("Build APP", "");
    }
}

I don't know how to hide it.

9708203--1386812--upload_2024-3-18_21-47-20.png

Try clicking the three vertical dots in the upper right. Check if "Debug" is selected, should be "Normal".

Or perhaps this is due to not having a public/SerializeField in that script. Try adding one.

yeah I see this too now, what is this?? it seems harmless but at the same time, Wizards are often for non technical folks, so the less visible options, the better.

my wizard has a public var and I still see this.

@CodeSmile wizards don't have 3 dots to switch between debug/normal. FWIW, my inspector is in Normal mode though

[quote=“chase_unity38”, post:3, topic: 942472]
yeah I see this too now, what is this?? it seems harmless but at the same time, Wizards are often for non technical folks, so the less visible options, the better.

my wizard has a public var and I still see this.

@CodeSmile wizards don’t have 3 dots to switch between debug/normal. FWIW, my inspector is in Normal mode though
[/quote]
emm… It’s not about the pattern(Debug/Normal) i saw Odin Also had this problem, but fixed it: https://discussions.unity.com/t/907463
I think it’s an engine oversight