Incomplete Syntax Highlighting in Visual Studios 2017

Hello All,

I am currently working through the “Create with Code” Unity Learn series, however I cannot seem to get the syntax highlight in Visual Studios 2017 to work completely. Most of the script I type autocompletes correctly and matches the “Create with Code” video examples, however the syntax highlighting seems to miss method names, some operators and, in the example below, some argument names.

I have tried a few things, including reinstalling both Visual Studios and Tools for Unity, but to the same result. Unfortunately, searching online has only found posts relating to Syntax Highlighting completely not working, Intellisense not working, or a combination of both.

I know this is a small problem but any help in understanding it would be greatly appreciated.

• Visual Studio Community 2017 4.8.03752

• Visual Studio 2017 Tools for Unity (Set to Auto update)

Try to update Visual Studio from 2017 to 2018 or 2019.
I am using Visual Studio 2019 preview and the syntax is working well.

Encountering the same issue. I get some things to behave as expected, such as main method names like Start() and Update() and even OnCollisionEnter(). But I don’t get anything for Vector3, for instance. Did you find a solution?