Increase size of obstacle - navmesh

I am having a problem with navmesh.

I have a large cube in the middle of my ground that is acting as an obstacle. I have set it to navigation static, and baked my mesh. At first test, my navmesh agents would path around it, but they would clip into the edges a little bit.

I tried to increase the size of the collider around the cube, but this changed absolutely nothing. This is what I obviously thought would increase the size of the hole it punched in the mesh. I even tried to put a much larger cube around it, and then sit the renderer to off, in attempt to increase the non pathable area around it. Still no success.

So how exactly can I manipulate the size of the hole an obstacl makes in the navmesh?

I finally found a workaround.

As explained here, one solution consists in creating cubes / spheres wherever you want your “not walkable” zones on the navmesh.
Bake, and then just disable them.

Works great for me!