Infinite black screen on game built with Unity 4.6 using Soomla Store

Hi everybody!

I’m trying to use Soomla to integrate some in-app purchase in my Unity apps ( I started Soomla’s store integration in an empty project under Unity 4.2, and I’ve managed to launch it on my android devices without any trouble.

But then, I came to a game project I’d like to integrate Soomla Store to. Before Soomla’s libs integration, the game were working perfeclty (under Unity 4.6). After integration and build with Unity 4.6 on a Mac OS X, my game remains on a black screen at start and does not react to anything, on both iOS and Android. (Work fine in editor)

I had a look to the logs, and after the mono lib loading, I have that log :

Unable to find type [UnityEngine.dll]UnityEngine.ResourceRequest

After that, no other Unity log…
A quick search on internet about this log did not give me satisfaction…

What is weird is that I tried to build this project with Unity 4.2 on a Windows PC… And the game starts correclty!
Does anyone have an idea about how to fix this bug? (except completely downgrading the project if possible)

Thanks in advance!

Edit: I’m using the last release version of Soomla Store and core, and I tried to build and rebuild again my project several times :slight_smile:

The problem is solved, thanks to Soomla’s support!

To be honest, I don’t know exaclty howdid I solve it, but if anyone encounters this issue in the future :

  • try to regenerate your project (libraries, plugins…),
  • check your player settings (stripping levels for example, try to disable it),
  • perform a complete new clean build.

I just had another error on iOS (“unrecognized selector sent to instance”) I’v been able to solve thanks to this link :

Hope this will help someone.