Input device not connected

I keep getting the error that 'input device not connected' when in Game Mode, regardless of what device/device controller I am using; I have checked and rechecked the scripts and such, but I can't figure out what is happening.

(EDIT2: Erm don't know why I didn't clarify this, but it's just not reading the input when I'm in game mode; so nothing happens when I push the button(s).)

(obviously, my keyboard/mouse is working and connected)

Any suggestions?

EDIT: Actual copy paste;

Failed to read input report: The device is not connected.

EDIT2: I've done a little more sleuthing, and determined a few things;

1) In the error it references an error in a file, "....\PlatformDependent\Win\RawInput.cpp at line: 589". I don't know what exactly that means, but when I try to find that file I can't find it... so I'm not sure what to think. I'm not sure where it's supposed to be, though.

2) It is likely hardware and specific install independent; tried it on different computers (with a portable install on my flash drive) and tried a separate install on my own computer. -> Probably means it has something to do with the current build of Unity (maybe something to do with Unity 3?), or the specific code; either that or the Input mgr itself. I very much doubt it's a hardware problem.

3) However, I've checked up on the specific code, in several cases, and I don't see any problems; in one case I used the default controllers (tried all of them) from the Unity editor, in another I used one I downloaded from UnifyCommunity, and another I wrote my own. Same situation either way. I've also checked and messed around with the Input Manager. No problems that I can see there. I thought it might have to do with how both Horizontal input axes had the same name (erm yeah a long shot I know) but predictably that didn't make a difference... and it doesn't explain why it's not detecting input from my Joystick either (logitech, so it should be good).

This sounds like a Unity bug. Could you please report it? Even though you say that this problem is device independent it would be nice to know which particular device you are using (I'm not seeing anything similar with my joystick). I have made some changes to the way input devices are handled for the next release but this might be a deeper problem with device drivers (in which case my hands are tied). As user Statement has already suggested you should make sure it works fine in Control Panel/other games and make sure you restart Unity after connecting/disconnecting device.

I think the best thing to do here is to report a bug, I have also tested with a joystick and I didn't get any error messages regarding any input device.

I really need an example project from you to investigate with and run the same tests. This will help me determine a cause or get this fixed for you in our up and coming release, so please attach this to your bug report before submitting it.

Cheers :)