Inspector window transform component showing ONLY local cordinates

Hi guys,

im not sure wht i did, but my inspector window has chnged and its showing the local cordinate system instead of world space. i have aattached a screen shot. i have failed to get it to turn back to original one. im using unity 4.2. i think something changed when i was importing an asset from the store. any ideas?

I’m going to try to clear up any confusion regarding this. What you are seeing is not “Local Coordinates”, it is the Quaternion Rotation of the selected object. By default Unity displays rotations in the inspector as an Euler rather than Quaternion, which is why it looks so incredibly different.

There is a possibility that attempting to fix this can cause other content in your project to stop functioning properly. However, here are some steps to get you started:

Somewhere in your project there is a custom inspector for Transform. Check through your project assets for folders named “Editor”. Provided the editor extension allows access to the code (e.g. it isn’t in a DLL) you could edit it to remove the reference to the custom inspector. However, once you find out what script is responsible I would highly recommend contacting the author of the package and ask them if they could include code to make this an option for the package.