Install UnityHub on Fedora 36

Hi,

I use the instructions on https://docs.unity3d.com/hub/manual/InstallHub.html but I have error when i Install unityhub :

chmod: cannot access '/opt/unityhub/chrome-sandbox': No such file or directory

and when I launch unityhub, it crash with this error :

ERROR: Licensing SDK logging callback is not registered. Please use 'registerLoggingAdapter' function from the SDK to do so.

How can i resolve this ?

3 Likes

I also have this issue. Spent all day looking yesterday and didn't find a solution. I've just gone back to Windows for now until it gets fixed.

Though given the earliest reference I saw to it giving a blank screen on ubuntu (which is what I see with that console error) was back in February, I'm not holding my breath...

I have another lead ! If I launch from command line, I have the previous error (registerLoggingAdapter) BUT if I also launch unityHub from normal GUI, I have another errors :

libva error: vaGetDriverNameByIndex() failed with unknown libva error, driver_name = (null)
(electron) Security Warning: A WebContents was just created with both webviewTag and contextIsolation enabled. This combination is fundamentally less secure and effectively bypasses the protections of contextIsolation. We strongly recommend you move away from webviews to OOPIF or BrowserView in order for your app to be more secure
Error occurred in handler for 'localConfig/getHubConfig': No handler registered for 'localConfig/getHubConfig'

1 Like

I have the same error here, but in my case, the hub application starts in a weird way:8126774--1053923--upload_2022-5-13_23-46-36.png

Exactly same Error on Fedora 36 with KDE (and Wayland)

I'm experiencing the same error. If required can provide furtuer info.

Image 1: The error on the terminal and the app with developer tools open, showing no errors.
8158997--1060583--upload_2022-5-26_11-50-19.png
Image 2: System specification.
8158997--1060586--upload_2022-5-26_11-51-1.png

8158997--1060577--upload_2022-5-26_11-48-46.png
8158997--1060577--upload_2022-5-26_11-48-46.png

I also can't get it to work.

OS: Fedora Linux 36 (Wayland)
Kernel: 5.17.11-300.fc36.x86_64
CPU: AMD Ryzen 5 3450U with Radeon Vega M
GPU: AMD ATI Radeon Vega Series / Radeon

If I run the application I get a black screen
8165738--1062338--upload_2022-5-29_17-27-46.png

I get this error in the terminal:

ERROR: Licensing SDK logging callback is not registered. Please use 'registerLoggingAdapter' function from the SDK to do so

And if I run it as sudo unityhub:

libva error: vaGetDriverNameByIndex() failed with unknown libva error, driver_name = (null)

Same error with fedora 36 cinnamon

Same error for me.

Same error but on ubuntu when running sudo unityhub --no-sandbox
I used the --no-sandbox argument because of another error i got when running without that argument
FATAL:electron_main_delegate.cc(252)] Running as root without --no-sandbox is not supported. See https://crbug.com/638180

Think I am going to have to give up trying to use unity on linux for now...

Ubuntu 20.04.4 LTS

On Fedora36, try this:

sudo dnf install openssl1.1 openssl-libs

2 Likes

[quote=“bretternst”, post:11, topic: 879888]
On Fedora36, try this:

sudo dnf install openssl1.1 openssl-libs
[/quote]
Now the hub launches and shows login screen,
8191656--1067928--upload_2022-6-9_7-26-53.png
but neither “sign in” nor “create account” buttons do anything.
This is what the console shows
8191656--1067922--upload_2022-6-9_7-26-4.png

8191656--1067922--upload_2022-6-9_7-26-4.png

I have the exact same error does anyone have a solution for this ?

I was also getting a blank screen when launching unityhub. I tried to run it with sudo and got
'FATAL:electron_main_delegate.cc(252)] Running as root without --no-sandbox is not supported'

So I just ran unityhub with --no-sandbox and it started just fine (without sudo!). I still get the electron security warnings but I can login and install an editor.
I installed unityhub from the AUR.

I have the exact same issue as well, I looked for an example app-update.yml with no luck to just try and resolve the issue. I did manage to download and manually activate a version of Unity without the hub. A pain, but it works. I can’t seem to find any information on this anywhere.

Try with these codes in your terminal.

sudo dnf check-update 'echo -e "[unityhub]\nname=Unity Hub\nbaseurl=https://hub.unity3d.com/linux/repos/rpm/stable\nenabled=1\ngpgcheck=1\ngpgkey=https://hub.unity3d.com/linux/repos/rpm/stable/repodata/repomd.xml.key\nrepo_gpgcheck=1" > /etc/dnf.repos.d/unityhub.repo'

sudo dnf install unityhub

Does anybody have some new info on this? I sadly fail on the sign-in button of the first screen. Pressing it just does nothing...

I installed the old Openssl version in case that was a problem (dnf install openssl1.1 openssl-libs), I used the --no-sandbox option, I tried the stable and beta version, I specified the LIBVA option (LIBVA_DRIVER_NAME=amdgpu). But nothing seemed to help. :/

If there are no new fixes, is it by any chance possible to activate a public licence and start unity through the console bypassing the hub? I did manage to install the newest Unity version through the old AppImage hub. Just the licencing won't work.

Thanks in advance for any help!