Installing Unity on Linux XFCE Ubuntu 16.04

I am trying to install Unity from the official Linux build page.

Unfortunately, I have trouble installing the latest .deb, and the new download assistants, because of my inexperience, are near impossible to run.

installing the .deb

When I run the usual syntax for installing .deb files (sudo apt-get install unity-editor_amd64-2017.2.0f1.deb), the Terminal returns, among other things, errors:

Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package unity-editor_amd64-2017.2.0f1.deb E: Couldn't find any package by glob 'unity-editor_amd64-2017.2.0f1.deb' E: Couldn't find any package by regex 'unity-editor_amd64-2017.2.0f1.deb' }
(the /code tag doesn’t work for me without that curly bracket at the end. Linux did not return that.)

Installing through the 2017.3+ download assistants

I have tried installing through the new download assistants, using the installation instructions provided on the “Unity on Linux” forum (here)

I run chmod +x ~/Downloads/UnitySetup-2018.2.3f1
and the Terminal returns nothing. I assume it has worked. (also, the check box next to “Allow this file to run as a program” under the Permissions panel in the file browser is filled)

This should, in theory, allow the installer to run, right?

Then I run ./UnitySetup-2018.2.3f1 only to receive the error bash: ./UnitySetup-2018.2.3f1: No such file or directory.

-short, frustrated growl-

I have even tried adding -unattended and -install-location! What am I doing wrong?

P.S. Thanks in advance. Bonus points if you tell me the best way to input code-style elements (the /code tag and such)

This did the trick on Xubuntu 18.04. I just completed the installation with the latest installer.

chmod u+x UnitySetup-2017.4.9f1