Instantiated Object Not Animating

I’m creating a game where the player needs to navigate a character through obstacles. 10 obstacles are created at the start of the game and then one more is created each time the character successfully traverses an obstacles. Here is the script that activates the obstacle instantiation:

#pragma strict
private var script:obstacleMovement2;

function Start () {
	 script =GameObject.Find ("obstacleContainer").GetComponent(obstacleMovement2);
	 Debug.Log(script);
}

function OnCollisionEnter2D(collider: Collision2D){
		script.instantiate();

}

It gets the obstacle gameobject and then calls the function “instantiate()” from the script “obstacleMovement2” that is attached to the obstacles. Here is the script “obstacleMovement2”

var pointB : Vector3;

static var range : int = 17;
var speed : int;

static var distance : int = 36;
static var CountGenerator : int = 10;
static var angle : float = 0f; 
var obstacle:GameObject;
var generateOne : int = 1;


    
function Start(){
	generate();
}

function OnLevelWasLoaded (level : int) {
    distance = 36;
    CountGenerator = 10;
}

function generate(){
	
	if (CountGenerator >= 0){
		yield WaitForSeconds(0.2);
		
		speed = Random.Range(2, 5);
		
    	var pos=Vector3(distance,3.54478,0.731279);
   
    	var clone = Instantiate (obstacle, pos, Quaternion.identity);
    	
    	distance += 10;
    	
    	CountGenerator = CountGenerator - 1;

    	
    	var pointA = transform.position;
    
	    var pointAX = transform.position.x;
	  	var pointAY = transform.position.y;
	  	var pointAZ = transform.position.z;
	  	
	    while (true) {
			yield MoveObject(transform, Vector3(pointAX,-5,pointAZ), Vector3(pointAX,10,pointAZ), 3.0, true);
			yield MoveObject(transform, Vector3(pointAX,10,pointAZ), Vector3(pointAX,-5,pointAZ), 3.0, false);
		}
		
		
		
	}
}



function instantiate(){
		speed = Random.Range(2, 5);
		
    	var pos=Vector3(distance,3.54478,0.731279);
   
    	var clone = Instantiate (obstacle, pos, Quaternion.identity);

    	distance += 10;

    	var pointA = transform.position;
    
	    var pointAX = transform.position.x;
	  	var pointAY = transform.position.y;
	  	var pointAZ = transform.position.z;
	  	
	    while (true) {
			yield MoveObject(transform, Vector3(pointAX,-5,pointAZ), Vector3(pointAX,10,pointAZ), 3.0, true);
			yield MoveObject(transform, Vector3(pointAX,10,pointAZ), Vector3(pointAX,-5,pointAZ), 3.0, false);
		}
}

    
function MoveObject (thisTransform : Transform, startPos : Vector3, endPos : Vector3, time : float, orientation) {

    var i = 0.0;	
    var rate = speed/time;
    

    if(orientation){
    	
    	angle = Mathf.Lerp(0, 0, 1);
    	
    	
    	
    	var pointAX = transform.position.x;
	  	var pointAY = transform.position.y;
	  	var pointAZ = transform.position.z;
    	
    	for (var child : Transform in thisTransform) {
  			child.rotation = Quaternion.Euler(0,0,angle);
    	}
    	
    }else{
    	angle = Mathf.Lerp(0, 180, 1);
    	
    	for (var child : Transform in thisTransform) {
  			child.rotation = Quaternion.Euler(0,0,angle);
    	}
    }
  
	while (i < 1.0) {
  	  i += Time.deltaTime * rate;
  	  thisTransform.position = Vector3.Lerp(startPos, endPos, i);
  	  yield;
    }
}

instantiate() creates the obstacle while appending to the distance between the last obstacle and the one generated and then calls the MoveObject() function to start animating/moving the obstacle. Problem is that instantiate() is successfully creating the obstacle but failing to make it move via the MoveObject() function. While the first 10 obstacle that get created at the start of the game are successfully moving/animating. Can someone please give me any pointers as to what is going wrong here? Thank you.

The problem seems to be that CountGenerator goes to zero, and so the body of your generate() function is no longer executed.