Instantiating Mesh Error - Mesh has Instance added?

Hey Guys,

I’m having trouble with a scene where all of my prefab’s mesh models are being replaced with a version that adds “Instance” to the file name. The asset still draws on my computer, but our lighting team is saying lightmaps don’t work on these assets AND updating the mesh models/prefabs don’t update these assets.

This is just one of the 700-something warnings I’m seeing in the Console Window:

Instantiating mesh due to calling MeshFilter.mesh during edit mode. This will leak meshes. Please use MeshFilter.sharedMesh instead.
UnityEngine.MeshFilter:get_mesh()
EditorObjExporter:MeshToString(Component, Dictionary`2) (at Assets/Scripts/Editor/EditorObjExporter.cs:37)
EditorObjExporter:MeshesToFile(Component[], String, String) (at Assets/Scripts/Editor/EditorObjExporter.cs:207)
EditorObjExporter:ExportWholeSelectionToSingle() (at Assets/Scripts/Editor/EditorObjExporter.cs:312)

I’ve had this issue before and the only way I can fix it is to break all of my prefabs… but first I need to update those assets with the final version. Does anyone know what is going on here? I’m sorry if this is a repeat issue but I looked high and low with no solution. Also, as just a little ol’ artist I’m not technically enabled.

GOT IT!
We have a scene exporting tool that exports all of the geo to OBJs. It appears this plug-in is the culprit. Sorry I don’t know any info about this plug-in.

Also of note, the other artists who use this tool never saw this issue before, so maybe it’s my graphics card.