"Invalid AABB" error whenever rigidbody moves

I’m getting an error that says “Invalid AABB b0” whenever the player in my game moves, which is a rigidbody. Since it’s AABB I’m assuming it has something to do with collision, but the error throws whenever the player is moving, even if it’s not hitting anything.

Selecting the error reveals nothing, it’s not anywhere in my code but presumably something with Unity itself. Image below.

Latest Unity, using 3D physics. The game seems to run perfectly fine, but getting 100+ errors constantly while playtesting makes it hard to debug anything. The error fires every frame while the player’s rigidbody is in motion.

Thanks!

I had the same problem. I found that I accidentally set a GameObject’s Scale that has a Rigidbody to 0,0,0. Just changing that to a non-zero value solved the problem.

Solved it. For anyone else with a similar problem, it was because of the way I was instantiating the player. I was using Instantaite(Resources.Load(gameObject etc etc)) to do it, then on the next couple lines setting the position and rotation independently. By moving the position and rotation set into the Instantiate function itself:

playerObject = Instantiate(Resources.Load("Player", typeof(GameObject)), target.transform.position, target.transform.rotation) as GameObject;

That seems to have fixed it. Not sure why, but it works!

I ran into this problem, and thought it was something to do with the Rigidbody (since it was happening when two rigidbodies collided), but I discovered in my instance that it was because I’d passed the NavAgent’s desiredspeed.magnitude to the animator, and when the rigidbodies collided, that created a speed of Zero… which I was using as a parameter for the animation speed of Walk… The end result was that the character that stopped due to collision suddenly had all its bones with positions and rotations of nAn…

I had particles with world collisions AND particle stretching from velocity. So when I wasn’t moving, the collisions AABB box would have been 0

Happened to me with a linerenderer, i think the size was set to 0

This happened to me with two rigibodies, both of them with the collision detection set to “continuos or dynamic continuous”. When I set the rigidbodies collision detection to “discrete” the problem was solved.

I just wanted to add a note here, that I solved this problem for me, by going into my blender model file, and adding a couple faces to a child object that only contained a vertex. After re-import, the errors stopped.