invalid binary no email

I am trying to get my app uploaded to the ios app store for beta testing.
Everything was working great until I upgraded to xcode 8 and I am using unity5.3p6

The app passes validation, and uploads with no problems both through organizer and application loader.

Then within about a minute after the upload finishes, I get an “Your app has changed to Invalid binary” message from itunes connect with no other information and no email from email about the reason why!

When I view the app in itunes connect, there is a red exclamation with the message “This build is invalid.”

I have tried many different settings and I have no clue what could be causing this issue.

I have tried turning off compressing the png for the icons, setting all the splash screen images, building for iphone only.

I am now trying to revert to xcode 7.3.1 to see if this fixes the issue.

Is anyone else having this problem/solved this issue?

downgrading from xcode 8 to xcode 7.3.21fixed this issue for me.