"Invalid Data File" error in every server I try (Facebook game)

I have had this error message for 2 days of various tests: “Invalid Data File” and when I click details it shows a popup saying: “Data file is corrupt (not a Unity web player file)”.
I tried uploading the .unity3d file on Dropbox, Google Drive, Sky Drive, Yahoo GamesNet server and all show the same error message (or I couldn’t even configure it at all).
I have already pushed the launch of my game on Facebook (main platform) for 2 days and this doesn’t seem like it has an end.
How can I fix this problem?

alt text
alt text

This is the link where game is hosted for now: GamesNet Yahoo server of my game.
Infinite gratitude to the one who can find a solution to my problem.

So, I look in the html file, and come across the URL for the unity3d file:


When I download that with curl, and look at the file, it’s a text file that shows:

Sitebox Error: You tried to serve a resource ('Web.unity3d') directly. You have to use the url
tag to get the proper url to the resource in your templates: {% url 'Web.unity3d' %}

So, my assumption would be that Sitebox (whatever that is) doesn’t like the way the unity3d file is handled on the website. So when you request it you get this text message instead of the unity file.