iOS build error with Unity Ads

Hello! I’m building a game for Android and iOS. I have integrated Unity Ads into my game. However, I get a build error in xCode when compiling, only when I enable Unity Ads for iOS through the services tab in Unity. Here’s what is says:

“error: make directory /Users/Alex/Library/Developer/Xcode/DerivedData/Unity-iPhone-fmwfrgxbdxuumlefynyaitzagqcf/Build/Products/Release-iphoneos/ File exists
error: couldn’t remove ‘/Users/Alex/Library/Developer/Xcode/DerivedData/Unity-iPhone-fmwfrgxbdxuumlefynyaitzagqcf/Build/Products/Release-iphoneos/’ after command failed: Directory not empty”

There seems to be some conflict with the UnityAds.bundle folder. It won’t work if I delete that one either. To be clear: it works just fine if I don’t enable Unity Ads for iOS.

Solved it by mailing unity ads support!

Turns out you shouldn’t both import the unity ads package from the asset store AND enable it from the services tab. It’s one or the other. I prefer to just enable it from the services tab, so I removed the imported package, and now it works!