iOS Build throwing error on launch.


I am getting this error when I build and run my project through xcode after building in Unity.

2016-04-29 15:57:20.940 project[973:510098] [PW]  *+[UIApplication(Pushwoosh)] Pushwoosh: Initializing application runtime*

2016-04-29 15:57:21.137 project[973:510098] → registered mono modules 0x1551140
2016-04-29 15:57:21.569 project[973:510098] -[__NSCFString containsObject:]: unrecognized selector sent to instance 0x167739a0
2016-04-29 15:57:21.844 project[973:510098] Uncaught exception: NSInvalidArgumentException: -[__NSCFString containsObject:]: unrecognized selector sent to instance 0x167739a0

0 CoreFoundation 0x23e1f9a3 + 150
1 libobjc.A.dylib 0x235bae17 objc_exception_throw + 38
2 CoreFoundation 0x23e25325 + 0
3 CoreFoundation 0x23e22f51 + 700
4 CoreFoundation 0x23d4e2f8 _CF_forwarding_prep_0 + 24
5 UIKit 0x28643ce1 + 400
6 UIKit 0x2862c043 + 1362
7 UIKit 0x286406dd + 36
8 UIKit 0x28629653 + 134
9 FrontBoardServices 0x254c2c07 + 18
10 FrontBoardServices 0x254c2ab9 + 224
11 FrontBoardServices 0x254c2db9 + 48
12 CoreFoundation 0x23de1e6f + 14
13 CoreFoundation 0x23de1a5d + 452
14 CoreFoundation 0x23ddfdcb + 794
15 CoreFoundation 0x23d2f2e9 CFRunLoopRunSpecific + 520
16 CoreFoundation 0x23d2f0d5 CFRunLoopRunInMode + 108
17 UIKit 0x283f9b6d + 524
18 UIKit 0x283f40b9 UIApplicationMain + 144
19 project 0x000275b7 main + 230
20 libdyld.dylib 0x239d7873 + 2

2016-04-29 15:57:21.845 project[973:510098] *** Terminating app due to uncaught exception ‘NSInvalidArgumentException’, reason: ‘-[__NSCFString containsObject:]: unrecognized selector sent to instance 0x167739a0’

*** First throw call stack:

(0x23e1f98b 0x235bae17 0x23e25325 0x23e22f51
0x23d4e2f8 0x28643ce1 0x2862c043 0x286406dd
0x28629653 0x254c2c07 0x254c2ab9 0x254c2db9
0x23de1e6f 0x23de1a5d 0x23ddfdcb 0x23d2f2e9
0x23d2f0d5 0x283f9b6d 0x283f40b9 0x275b7 0x239d7873)

libc++abi.dylib: terminating with uncaught exception of type NSException
I cannot figure out what the issue is, all I know right now is the game runs fine in editor and on android.
I could really use some help figuring out this problem. I can provide any additional information upon request.

Have you solved your problem? I have the same issue here…

Any luck? Same issue…

Same Issue Here!!! Been trying to get my game in the App Store for 2 weeks and been rejected 10 times for IPV6. But been getting this error trying to debug in XCode.

Anyone find a fix for this?

Unity 5.4.4p4

I am not sure whether this applies to every case but I had exactly this error today when I tried to run an app that, despite targeting iOS 10 (Target minimum iOS in Player Settings), requires iOS 11 features.

The error came up when I tried to run on a iOS 10 device. The same Xcode project compiles and runs fine on any other iOS 11 devices. In my specific case the framework that requires iOS 11 features is ARKit.

So, even though this is very unlikely to cover all cases this error comes out, you do want to check you’ve the right iOS version for the frameworks you’re using.