iOS Export: Empty Xcode Project

About a month ago with the same version of Unity (5.1.1) and Xcode (6.3.2) I wasn’t having this problem, but I tried to build a new version of an iOS project I’m working on and am getting an Xcode project without any actual code, assets, or libraries… just an .xcodeproj file. Of course, when I try to open the project, I get:

Project/Users/administrator/Documents/Unity Builds/project_name/Unity-iPhone.xcodeproj cannot be opened because it is missing its project.pbxproj file.

I CAN use Unity Cloud Build to deploy the same project with the same settings, but I am specifically planning to use Xcode’s debug/profiling tools to solve a device-specific runtime issue, so that’s not much help.

Has anyone encountered this before? The only thing I changed in the publishing settings with the bundle identifier. I tried toggling back and forth between the several Debug settings and back to Release, but to no avail.


I’d been saving the project as Unity-iPhone.xcodeproj, so what I ended up doing was creating a package with that name, which shows up as an Xcode project file in Finder but actually has files within it.

On the off chance that a similarly Mac-illiterate individual ends up with this problem, make sure your “Save As” field when building from Unity is not defaulted to Unity-iPhone.xcodeproj ~or~ simply right-click the exported file and select “Show Package Contents.”

I had the same problem, but I just don’t have anything appear at all. I tried transferring the files to a new scene, but that still didn’t work. I have no idea what to do. I’m working on it, but I need some help.