iOS ignoring texture's wrap mode if the Texture Type is Advanced

I need a texture to NOT use mipmaps, and also be in “repeat” wrap mode.
So I set “Advanced” texture type and set these values up. Everything works ok on PC and Android… but for some reason, not on iOS.

The texture uses “clamp” on iOS, even if “repeat” is set. If I change the type to “Texture”, then it works with “repeat” mode, but it will use mipmaps (which I don’t want). “Override for iOS” is disabled.

What can be causing this? And is there a solution, or even a workaround?

Just in case anyone experience this as well, I’ve solved. Making the texture POT was the solution. It seems that iOS can’t handle all the texture settings if the texture is NPOT, even if it’s set to “True color”. (This does not happens in Android or Windows)