iOS "Mute other audio sources" disabled but not working

On iOS the “Mute other audio sources” button doesn’t seem to be working in the player settings. It’s disabled but opening my Unity app still pauses Spotify and other background music, despite having 0 audio in my app. Testing on iPhone XS.

By manually write code PlayerSettings.muteOtherAudioSources = false; before BuildPipeline.BuildPlayer(), you can fix this bug.

HI @timwzw & @jeremydulong , thank you for your suggestions.
I noticed little improvement.

Before your workaround, starting UnityApp immediately killed background music.
After it, starting UnityApp let the music continue play (not always) till I’m initializing MIC. It kills background music.

This issue was reported: Unity Issue Tracker - [iOS] Unity Player does not respect the "Mute Other Audio Sources" toggle in Player Settings

however I dont understand what is there: 2018.3.8 has in the relase notes confirmation that bug was fixed and in the issue tracker is stated that only 2019.2 will be fixed.
Whatever, I’m using 2019.1.4 and problem still exists :frowning:

Any advices?
Case is simple: music visualization where the music could come from internal and external (MIC).