iOS Splash Image starting black for a few seconds before loading

Hi There, We’ve started running into an issue lately with our iOS builds where the loading image for the splash screen is starting out as Black before loading the graphic a few seconds later. We’re using unity pro with a relative sized image. The background color appears, it just has a black square for an icon for a few seconds first. After a few seconds the splash image kicks in. We haven’t been having this issue and it recently appeared on my phone. Deleting the app doesn’t seem to get rid of it, neither does setting the image to not be compressed (set to 16 bit).

I’d really appreciate any info on this if anyone has experienced similar issues,



Hi All,

Not sure what the original issue was really, I fixed it by manually generating legacy splash screens though. One issue with debugging that may be helpful was that it persisted when updating the build (even when the app was deleted) until I both deleted the app and shut down the device. I guess the splash screens are getting cached and so this clears the cache. I hope this helps save some folks some time, if anyone knows why this was happening, I’d still be happy to know.



I’m having the exact same issue. This wasn’t happening before. Also, I seem to see a thin black border around the splash image as well if I import the asset as texture. This gets fixed if I import the image as a sprite. Before this was happening, I loaded the image as a texture and there was absolutely no issue at all. I will try different settings and if I find a solution or the cause, I’ll post it here.

I face with the same problem. Here is my solution. I made a 1024x1024 png logo and I use new splash system(Image and background - %75 relative size) . I didn’t fill legacy textures. I use Advanced panel for my splash texture and RGB 24 Bit format. (It don’t effect final splash image size don’t worry.)

Also, @ElectricMonk says true for caching. Delete app from your phone and restart it. Build new solution and try again.

Hi everyone,
I know this is an old thread, but I had this problem and the solution was disabling the anti-aliasing option y quality settings.