iOS splash screen error

I just upgraded to iOS 5.1. I also upgraded Xcode to version 4.3.1 from 4.2.1. Now, when building a unity program for the iOS device (iPad), I get an error message:

“You are using Unity iPhone Basic. You are not allowed to remove the Unity splash screen from your game.”

I have not had this error before, and I have not removed the splash screen. Any ideas on how to remove this error ? I cannot otherwise build a program.

current unity version = 3.4.2f2

As suggested elsewhere in this forum, I reverted back to Xcode 4.3.0. This solved the problem.

Downloaded old Xcode from: Sign In - Apple

It seems Unity hasn’t supported the newest iOS and Xcode, yet

Hi, Have the same problem with the new Xcode,. However building ,armv7 , for iPhone only did solve the issue for now. Waiting for a fix as well.

Xcode 4.3.0 running on Mac OS X 10.7.3 Lion works fine for developing apps on the iPhone 4S running iOS 5.1 in the interim, till a fix from Unity is available.

I am running Unity 3.4.2f2 and it all builds correctly.

I notice Unity has announced release of their Unity version 3.5 on their website. Perhaps this new version fixes the problem (I have not had time to check the release notes on it yet).

I just tried the new Unity 3.5.1f2 with Xcode 4.3.2, and the prior reported iOS splash screen error has gone away, and my iPad app now compiles, links and runs ok (so far I, think).

However …

Xcode reports two errors, one labeled “uncategorized”, and the other “internal inconsistency”. These may be harmless (although disconcerting … I reported as “crash bug” … the closest ? option in the bug reporter).

Prior to this, I tried Unity 3.5.1f2 vs Xcode 4.3.0 (which I had been using without issue, mostly). Here the compile failed. This was fixed by doing this in Xcode:

Organizer → Projects → Delete derived data
(a fix discussed elsewhere in this forum)

I also had to change some icon settings under Unity’s player settings for iOS build. It then worked, after restarting all programs.