IOS Unity 5 UI, Font/Text not displaying/Disappearing

Hi all, I have a minor issue currently with our unity build where our app when built to IOS seems to not have any text show at all. The WebGL + Android builds work fine, however which is one of the oddities that leaves me stumped. The real issue comes from the fact that previously, it was working fine and seemingly the issue appeared at random. I’ve even backtracked everything I did to the date it was working last and it seems to not have fixed it.

Heres an example of what our app is supposed to look like:
62358-aaaaaaaaaaaaaaaaaaaa.png

But instead on IOS it appears as this:

We are using unity 5.3.0f4, which according to the little I found online should have the previous fix to the disappearing text issue. I have tried setting every single text field to overflow in both directions, using Arial, using a custom font, setting the custom font to dynamic and include data, setting it to use OS specific rendering modes, changed the font character type to unicode, deleting and re-importing the font files, among many other fixes among the list I have found online.

The IOS version we have is IOS 9. Has anybody else had this issue or a similar one that might have an idea on what the cause is? I’ve officially run out of ideas.

Thanks for any help!

I had the same problem and for me it was a problem due to different resolutions. The text would show in 16:9 (phone and editor) but not in 4:3 (iPad). I fixed this by setting the Vertical Overflow on the Text component from Truncate to Overflow.

This might not be the solution for everyone but for me it worked. I’m using Unity 5.4.0p4 btw.

I just had a similar issue where all the text in the game disappeared. It turned out that I had animated our UI font material in a prefab down to 0 and it applied this to the shared material throughout the game.
Symptoms: game ran fine except for missing text. Built to Android fine but with no text showing up anywhere in the game.