iOS Xcode "Could not write to device"

I have a game which I am trying to test on iOS devices. The game builds from Unity on my Mac with no errors. However, after I open the Xcode project and set the right signing profile etc and hit the play button Xcode successfully builds the project but I get an error message saying that it could not write to the device

This happens when I am using my iPad Pro, but not when I try with a colleagues iPhone 6.

I don’t get the error with other projects, just this project only.

Things I have tried (from stackoverflow and google searches):

  • Restarting my MacBook
  • Restarting my iPad
  • Deleting previous instances of the app from my iPad
  • Using a different Apple ID to sign the app

Is this problem likely to be related to something in my project or my build settings, or is the cause related to the device itself?

I am using the latest version of Xcode (Version 9) and Unity 2017.1

Ok, I solved this problem.

Somehow I managed to change the build settings in Unity so that the architecture was set to Armv7 instead of Universal. As my iPad has an arm64 processor, it wouldn’t work. Changing this setting in Unity or in Xcode solved my issue

Connecting my iOS device to the internet solved this problem for me.